Teraflex lift Clunk

Discussion in 'Renegade Modified Tech' started by Jeremiah, Sep 4, 2018.

  1. Jeremiah

    Jeremiah New Member

    Joined:
    Aug 13, 2018
    Messages:
    17
    Location:
    Rapid City SD
    We have the Teraflex lift on my wifes 17 Altitude 4WD and after a could days of driving it has developed a clunk in the front end. I disconnected the swaybar endlinks and the noise went away so I am guessing that's the issue. Has anybody else ran into this problem?
     
  2. Rogerdodger

    Rogerdodger New Member

    Joined:
    Sep 23, 2017
    Messages:
    1
    Location:
    Blue springs Missouri
    On 3rd set. Very disappointed
     
  3. BUtrlhhawk

    BUtrlhhawk New Member

    Joined:
    May 17, 2018
    Messages:
    27
    Location:
    Houston Tx.
    I have the ATP sway bar links. They have a tendency to get dirt in them and make a creaking noise.
     
  4. robinsonmac

    robinsonmac Member

    Joined:
    Dec 11, 2016
    Messages:
    92
    Location:
    fort Collins
    It's the sway bar bushings. I just keep mine disconnected. Changing the bushing is a lot of work because the brackets are riveted and not easily removed.
     
  5. Mrsig

    Mrsig New Member

    Joined:
    Sep 5, 2018
    Messages:
    29
    Location:
    Davie, FL
    Try putting grease on the bushings to see if that will help.
     
  6. robinsonmac

    robinsonmac Member

    Joined:
    Dec 11, 2016
    Messages:
    92
    Location:
    fort Collins
    Last edited: Sep 16, 2018
  7. BUtrlhhawk

    BUtrlhhawk New Member

    Joined:
    May 17, 2018
    Messages:
    27
    Location:
    Houston Tx.
    ATP uses a hym link on it's sway bar links (not sure of the spelling ) Kind of a rotating ball type link. Tried the grease seems to work, but if you go off road the grease attacks all kinds of grit dust dirt etc. Then back to square 1. Might try a lighter type grease ? Even on road eventually dirt gets in there.
     

Share This Page