DON'T TRUST YER DEALER? JeepCares...they really do!!

Discussion in 'Renegade Chat' started by FATKID66, Sep 16, 2019.

  1. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    I recently called my dealers service center for 5 issues/problems/repairs to my 16 TH. The first 2 he dismissed out of hand and said it was normal. He said the lag/loss of power when turning is normal and there's nothing that can be done, because there is no throttle cable its computer controlled. He said the fact that I burn 1 qt. of oil every 6 weeks/800 mi. is normal and it is stated as such in my owners manual. I couldn't find that anywhere. He said the other items, "multiple warning lights", "cruise control cancelling on its own" and a warranty fan issue would all be addressed at my service appointment. Also I was informed that I would be responsible to pay for the two repairs, (obviously not the warranty item), as I am out of warranty except for the engine/powertrain. My warranty was up in March, just my luck that 6 months later stuff starts happening. A google of my issues brings up others with similar issues that have been repaired by dealers either hunting & pecking parts to replace, to re-seating connectors to new batteries to repairing ground connections. I'm sorry but I dont trust this guy. I feel hes lying to me and stuffing me off. I'm not sure where to turn because im past lemon law, and dont want to threaten legal action if I dont have to. I also dont feel right just selling my problem to some poor schmoe and having someone else getting stuck with my problem. I typically buy a vehicle and run it till it stops. My last vehicle i drove to 137000 miles in 16 years till she up & died on me. Never had an issue...wasn't a Jeep, thats all I'll say...
    Anyone have similar issues? Anyone have any suggestions?

    HELP!!!!!:(
     
  2. Dgr401

    Dgr401 Well-Known Member

    Joined:
    Nov 21, 2015
    Messages:
    517
    Location:
    Rhode Island, USA
    I hear what you are saying about not trusting your dealer. My dealership recently changed hands and now whenever I go in for any kind of service they tell me I need to flush the coolant every 40k, manual says 150k or 10 years, change all transmission and differential fluid every 30k ($348), manual says to check at 40k, not replace and on and on. They said I needed new wipers, only 2 weeks old. Replace spark plugs $278. I am not planning on going back to them, I don't trust the new owners. Do you have another dealer in the area you could go to?
     
  3. JeepCares

    JeepCares Active Member

    Joined:
    Jul 24, 2015
    Messages:
    123
    Location:
    Mopar Headquarters, MI
    Hi @FATKID66

    We are terribly sorry to hear that you are experiencing this with your Jeep. If you would like additional support while your Jeep is in service, please send us a private message with your VIN, mileage, and dealer. We would be happy to escalate a case for you.

    Darlene
    Jeep Social Care Specialist
     
    Sleepy likes this.
  4. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    DGR: I do have other dealers in the area but I hate that they give you the hairy eye ball if you didn't buy your jeep from them. When I told my current dealer I would need a loaner I was told they wouldn't give me one b/c I bought it elsewhere. When I insisted that I bought it there and told him i could fax him a copy of the receipt, he changed his tune, although he told me he wouldn't have a loaner until at least October 1st. That tells me there is a bit of a double standard regarding where you purchase and service.

    Darlene: I will PM you tomorrow and hopefully we can speak on the phone & see what my options are.

    BTW, this is the same Ren that they had for a month in January and changed both the front and rear seals b/c it was leaking oil all over my driveway...
     
  5. persquank

    persquank Active Member

    Joined:
    Jun 24, 2016
    Messages:
    210
    Media:
    22
    Albums:
    1
    Location:
    MKE
    I want to talk about the 5 issues:
    1.Turning power loss/lag
    2.Burning oil
    3.Warning lights
    4.Cruise control
    5.Warranty Fan?

    For problem 1, I would experiment with turning off traction control or even try a 4wd mode. My theory is you are losing traction on the inside wheel setting off traction control which will cause power loss/lag for sure.

    Problem 2 should not be happening. Unless you have a V8 from the 80's you should not be burning oil that fast. Even if this is a normal thing for the 2.4 engine, it is not right. But I don't really have any advice for that one.

    Anyone with problem 3 should buy themselves an OBD2 scanner. They are as cheap as $15 on amazon. I have a fancy bluetooth one that displays on my phone. These allow you to see what the codes are on your own as well as clear the codes which I do all the time.

    Cruise control my be related to issue 3. The only other theory would be an electrical issue which would be very hard to diagnose.

    Lastly, the warranty fan. If this is your radiator fan, these are not that hard to replace on your own. You can buy one from places like rock auto and swap it out on a weekend.


    If you take a step back, overheating from a bad fan may cause the other issues. Excessive heat can cause the engine to burn oil, nerf power when cornering, set off warning lights and disable cruise control to prevent more overheating. So maybe that's all you need. You should be able to see you coolant temperature from you digital gauge cluster. Mine stays around 180-190 on a normal day.

    To talk about the dealerships. You have remember, they are running a "for profit" business. Sometimes they realize building a relationship on trust and respect will make them more money in the long run. Other times, they just take your money and move on to the next chump. If you are not happy with the service you are getting, you might have to find another place to go. And once you are out of warranty, there is less reason to go to a dealership in the first place.
     
  6. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    DGR, thanks for your insight. I think if the loss of power on turning was indeed a TC issue I believe when that comes into play i would see a warning light on the cluster. This has happened enough so that I do glance down to see if the engine has shut off, so I'm sure I would have noticed the light, we get a lot of snow during the winters here, and I see it often during the snowy days.

    I do have a scanner, I am updating it today as I have never had reason to put it on the Ren, only my older vehicles. I agree with the oil burn being excessive, despite the fact that the lying dealer told me that per FCA this is acceptable and in my owners manual...yeah, right...

    The warning lights have all gone away with the exception of the CEL which I'm sure will clear after the appropriate amount of miles and restarts have occurred. I'm leaning towards this actually being a battery/ground issue which I will diagnose/take care of myself. This may well be the root of the cruise issue as well.
    The recall/warranty cooling fan will need to be done by them, I insist they be held responsible for their bad design.

    Hopefully JeepCares really does and will be able to help...
     
  7. JeepCares

    JeepCares Active Member

    Joined:
    Jul 24, 2015
    Messages:
    123
    Location:
    Mopar Headquarters, MI
    @FATKID66

    I have responded to your PM with a phone number that you can call for additional support.

    Darlene
    Jeep Social Care Specialist
     
  8. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    Thanks Darlene, I will be calling you shortly, and as I suspected, when I went out to check batt voltage at lunch, the CEL has disappeared!
     
  9. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    This is the code: U1409 Implausible Left Front Wheel Speed Signal Received. Looks like a wiring harness issue, they did pull the engine in January to replace the rear seal.

    On the phone with JeepCares now...It seems that they do care!!:)
     
    Last edited: Sep 17, 2019
  10. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    OK, got hooked up with a new dealer for service...lets see what happens(fingers crossed)...:cool:
     
  11. JeepCares

    JeepCares Active Member

    Joined:
    Jul 24, 2015
    Messages:
    123
    Location:
    Mopar Headquarters, MI
    @FATKID66, Glad to hear it! Please feel free to keep us updated.

    Darlene
    Jeep Social Care Specialist
     
  12. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    Will do, I feel it is important for others to know they have somewhere to turn if they are in my situation!
     
  13. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    OK, WE HAVE RESOLUTION!!!!:D

    JeepCares hooked me up with a new Dealer/Service Dept., After they checked out all of my 5 issues they came up with a plan for the repair. They also worked as a liaison between the service manager and myself to explain my situation and concerns. I pick it up tonight, and will have to return it at 1000 miles for them to check the oil loss. As far as I'm told all the other issues have been taken care of...To be continued...
     
    JeepCares and Sleepy like this.
  14. IDoMy0wnRacing

    IDoMy0wnRacing Well-Known Member

    Joined:
    Apr 18, 2019
    Messages:
    478
    Location:
    Pioneer, California
    Awesome, good for you.
     
  15. JeepCares

    JeepCares Active Member

    Joined:
    Jul 24, 2015
    Messages:
    123
    Location:
    Mopar Headquarters, MI
    @FATKID66,

    Thank you for adding this update!

    Darlene
    Jeep Social Care Specialist
     
  16. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    OK, another Update: After two 1000 mile oil consumption tests my Ren has been 2 qts low at each...:(
    Initially the dealer wanted me to do another 1000 miles, not sure if they expected it to get better after the 3rd try or what.o_O
    In the midst of the 3rd 1K, FCA has thankfully decided to order me a new motor!! It'll most likely be in after the new year and I can get on with getting on...:cool:
    Stay tuned...
     
    IDoMy0wnRacing and Dgr401 like this.
  17. Dgr401

    Dgr401 Well-Known Member

    Joined:
    Nov 21, 2015
    Messages:
    517
    Location:
    Rhode Island, USA
    Glad to hear they are replacing the motor. Any resolution on your other problems?
     
  18. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    Everything else was resolved at the initial visit...except they replaced the wheel hub but must have routed the speed sensor wire improperly because it was damaged/pinched which has led to a few issues. :mad:
    They ordered a new cable and it will be replaced when they replace the engine.;)
     
    IDoMy0wnRacing and Dgr401 like this.
  19. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    OK, my lil Black & Blue is in for the engine replacement. The dealer says 7-10 days, (they can take as long as they need as long as shes fixed!!), the last place took a month to replace the front and rear seals a year ago...

    Patiently waiting...:cool:
     
    TerminusV and Dgr401 like this.
  20. FATKID66

    FATKID66 Active Member

    Joined:
    Feb 29, 2016
    Messages:
    171
    Media:
    25
    Albums:
    1
    Location:
    Dirty Jersey
    Still waiting...apparently there were 3 other engine replacements ahead of me...haven't even started it yet...
     

Share This Page