ATP 2.0 lift creaking noise

Discussion in 'Renegade Modified Tech' started by Band-Aid, May 25, 2018.

  1. Band-Aid

    Band-Aid New Member

    Joined:
    Jun 18, 2017
    Messages:
    4
    Location:
    Maryland
    Hi guys!

    I have a ATP 2.0 lift kit installed on my Renegade for a few months now and it's making a creaking noise on the driver side when it go over bumps. It gets pretty loud and it does make a little noise when turning the steering wheel but it's not to bad. Anyone also run into this issue? Any ideas?
     
  2. persquank

    persquank Active Member

    Joined:
    Jun 24, 2016
    Messages:
    143
    Media:
    14
    Albums:
    1
    Location:
    MKE
    Did you install it or did you have a shop install it? My guess is the bolts need to be torqued down again.
     
  3. Band-Aid

    Band-Aid New Member

    Joined:
    Jun 18, 2017
    Messages:
    4
    Location:
    Maryland
    I had a local shop install the kit. I'll try doing that and see if anything changes.
     
  4. Jodi

    Jodi New Member

    Joined:
    Jul 5, 2016
    Messages:
    5
    Location:
    Parkersburg, WV
    I recently had a local shop install the AVID 2” lift on my renegade. I ended up with a lot noise coming from the front end. Turns out almost everything was loose. Once I got it tightened up the clunking noise when away. As another owner told me, even if it’s just a hair loose it’ll make noise.
     
    Avid Essentials Team likes this.
  5. Nathaniel

    Nathaniel Member

    Joined:
    Mar 19, 2018
    Messages:
    77
    Location:
    DeLand Florida
    I had the same issue with creaking for about 2 weeks but after a while it just went away.
     
    Avid Essentials Team likes this.
  6. John

    John New Member

    Joined:
    Dec 1, 2015
    Messages:
    6
    Location:
    Hamburg, Michigan
    Yes, I have the ATP 2" lift and it had all kinds of creaks and clunks. Ended up being bad swaybar ends they sent. One actually broke in two at the weld (under normal driving). I removed the swaybar ends and it rides very smooth now, but has a bit more sway (not recommended for high speed maneuvers.)
     
  7. BUtrlhhawk

    BUtrlhhawk Member

    Joined:
    May 17, 2018
    Messages:
    42
    Location:
    Houston Tx.
    Had the same problem, turns out the shop forgot to tighten up the sway bar links. All good for now. ATP 2" kit.
     

Share This Page